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Abstract 11 

Synchrotron X-ray diffraction images are increasingly used to characterize not only structural 12 

and microstructural features of polycrystalline materials, but also crystal preferred orientation 13 

distributions. Diffraction data can be analyzed quantitatively and efficiently with the Rietveld 14 

method and here the detailed procedure is reported from the experiment to the calibration of the 15 

2D detector and full analysis of the sample. In particular we emphasize the advantage of doing 16 

the calibration inside the Rietveld least squares fitting instead of a preliminary graphical 17 

calibration. Then the procedure is described to quantify crystal preferred orientations with the 18 

Rietveld method implemented in software MAUD (Materials Analysis Using Diffraction). The 19 

process is illustrated for a US “Nickel” coin, a 75 at.% copper 25 at.% nickel alloy with fcc 20 

structure and a strong cube texture. 21 

 22 
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I. INTRODUCTION 26 

Recently we have described a procedure to obtain quantitative texture information from time-27 

of-flight (TOF) neutron diffraction spectra and this has been applied to several instruments such 28 

as HIPPO at the Lujan Center of Los Alamos National Laboratory (Wenk et al., 2010) and 29 

SKAT at the Joint Institute for Nuclear Research in Dubna, Russia (Wenk et al., 2012). Here we 30 

describe a similar procedure for X-ray diffraction images, particularly images collected at 31 

synchrotron radiation sources. These X-ray images need to be calibrated and transformed to 32 

diffraction patterns and a correct procedure for the calibration is important to obtain optimal 33 

results. In addition, images collected in situ at high pressure may show distortions due to the 34 

influence of anisotropic stress. Smaller distortions are also present in the case of residual stresses 35 

and a special procedure is necessary to separate distortions due to detector errors from effects of 36 

lattice strains. The high resolution of X-ray diffraction images also allows characterization of 37 

microstructural characteristics such as grain size and grain shape. 38 

Emphasis is on quantitative characterization of preferred orientation patterns in 39 

polycrystalline aggregates. The orientation of crystals (or texture) has a profound influence on 40 

anisotropic physical properties, which depend on properties of single crystals and the orientation 41 

distribution. Texture has long been studied in metals and rocks (see Kocks et al., 2000 for details 42 

and applications) and we assume that the reader is familiar with the basic principles of texture 43 

analysis and texture representation. Texture or crystallographic preferred orientation (CPO) 44 

describes the orientation of crystallites of phases that compose a material, relative to sample 45 

coordinates, using a three-dimensional statistical orientation distribution function (ODF). Even 46 

though the computer programs used for data analysis rely on the ODF, we will only use pole 47 

figures for representation. A pole figure is a two-dimensional projection of the three-dimensional 48 

ODF and is easier to visualize. It displays the probability density of finding poles perpendicular 49 

to hkl lattice planes relative to the sample coordinate system. Textures are not only important for 50 

assessing deformation histories and calculation of physical properties of polycrystals, they are 51 

also essential for crystal structure refinements (e.g. Lutterotti and Bortolotti, 2005; Grässlin et 52 

al., 2013), quantitative phase analysis of aggregates with preferred orientations, as well as the 53 

analysis of macroscopic stress states (e.g. Lutterotti et al., 2004). While texture analysis is the 54 

emphasis of this presentation, we recommend the same procedure for synchrotron diffraction 55 
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image analysis of samples with random crystallite orientation, including structure analysis of 56 

highly disordered materials (e.g. Battocchio et al., 2012). 57 

Experimental methods used to obtain diffraction images are briefly described. The Rietveld 58 

method implemented in the program package MAUD, which was originally developed for 59 

neutron diffraction (Lutterotti et al., 1997), is then applied to diffraction images. Since the first 60 

such application to dinosaur tendon and salmon scale (Lonardelli et al., 2005), procedures have 61 

been refined and have become standardized. A metal coin (US “nickel”) is used as an example 62 

for data analysis. This sample is very straightforward to analyze; thus beginners should be able to 63 

follow our procedure on their own. In the Rietveld code MAUD there are many options on how 64 

to proceed to arrive at the same answer. Here we follow one (and occasionally point out other 65 

possibilities) leaving it to the more experienced user to discover the full variety. 66 

Readers should first consult our publication on neutron diffraction texture analysis (Wenk et 67 

al., 2010) where the situation is more straightforward and where many options are described, 68 

including graphic representation and texture displays. This will not be repeated here. In a 69 

companion paper (Part II) we will extend the method to complex materials such as multiphase 70 

shale and in situ deformation studies at ultrahigh pressure (Wenk et al., 2013). In two 71 

attachments we describe step-by-step procedures for data analysis in MAUD and provide data 72 

sets that can be used by readers. 73 

 74 

II. DIFFRACTION EXPERIMENTS 75 

In a typical synchrotron diffraction texture experiment, monochromatic radiation is used, the 76 

sample is analyzed in transmission, and the diffraction image is recorded with a CCD camera or 77 

an image plate detector (Figure 1). For the coin sample, high-energy (hard) X-rays with a short 78 

wavelength (λ = 0.10798 Å) were used. Hard X-rays have high penetration depth and for a 79 

medium absorbing material the sample dimension can be up to 2 mm in thickness without 80 

significant intensity loss. The X-ray diffraction measurements were done at the BESSRC 11-ID-81 

C beamline of the Advanced Photon Source (APS) at Argonne National Laboratory. Similar 82 

experiments can be done at other beamlines on different synchrotron sources (among them ALS, 83 

ESRF, HASY). The specimens are typically prepared into 1-2 mm thick slabs with parallel sides 84 

and mounted on a goniometer with an aluminum pin for rotation (Figure 2). The beam size is 85 

about 0.5-1 mm in diameter, and the detector, in the case of our experiment, was positioned at a 86 
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distance of about 1850 mm from the sample. The angular range that is recorded depends on 87 

wavelength and sample-to-detector distance. 88 

Figure 3b shows a diffraction image of an American “nickel” coin, composed mainly of 89 

copper, with Debye rings corresponding to reflections on hkl lattice planes. The azimuthal 90 

variations of X-ray intensity immediately indicate lattice preferred orientation. Debye rings are 91 

smooth, indicating excellent grain statistics, which is a prerequisite for a quantitative texture 92 

analysis with the Rietveld method. 93 

As the relative orientations of crystals and sample are crucial to texture analysis, the 94 

diffraction image recorded by the detector must correspond to a view from the sample in the 95 

direction of the incident beam. This is not trivial and can be verified by taking an image with an 96 

object placed in front of the detector that produces an asymmetric shadow, and then viewing the 97 

image to verify its correct orientation. It may be necessary to invert or rotate the image prior to 98 

the data analysis. 99 

A diffraction image contains reflections from many lattice hkl planes of many crystals, each 100 

obeying Bragg’s law. In terms of pole figure coverage on a sphere, this corresponds to two small 101 

circles (due to the center of symmetry imposed in a diffraction experiment, Figure 4a). A single 102 

diffraction image is not very satisfactory for pole figure coverage and often is not enough for 103 

quantitative texture analysis. In order to improve coverage, the sample is therefore tilted around 104 

an axis perpendicular to the incident beam (YM-axis in Figure 4a). Generally images at different 105 

omega angles (ω) are recorded and correspondingly the coverage is improved (Figure 4b). 106 

Information from several images has to be combined for quantitative texture analysis. In the case 107 

of the nickel coin, five images were collected at ω=-40º, -20º, 0º, 20º, 40º, providing a coverage 108 

as shown in Figure 4b. To further improve coverage, the sample could be mounted in different 109 

directions and corresponding images could be combined. This was not done here. During the 110 

exposure, the sample can also be translated along the horizontal axis to increase the volume 111 

average and grain statistics (in this case from –2 to +2 mm). The sample coordinate system is 112 

defined by three axes XM, YM, and ZM and corresponding rotations χ, ω, and φ define the 113 

orientation of the sample (Figure 4a). 114 

The X-ray diffraction experiment has to satisfy the following conditions: 115 

• The wavelength must be known to refine instrument parameters. 116 
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• The precise location of the primary X-ray beam needs to be established by using a 117 

metal pin mounted on a goniometer head to assure the beam is at the center of all 118 

goniometer rotations. In our case the large instrument goniometer needs to be translated 119 

until the horizontal ω rotation axis is in the beam center. Generally this center position is 120 

viewed through a telescope with crosshairs for mounting samples for texture analysis in 121 

the correct position and the axis rotated to verify that no movements of pin tip can be 122 

detected through the telescope. 123 

• When measuring textures, it is imperative to know the orientation of the sample 124 

relative to the diffraction instrument, and thus the directions of diffraction vectors relative 125 

to the sample for all diffraction patterns. Make necessary sketches! Figure 2 shows the 126 

coin as viewed from the incident beam. Be sure that sample tilts correspond to ω-127 

rotations as illustrated in Figure 1. 128 

• The sample needs to be centered in the ω rotation axis to ensure the same volume 129 

element and sample-detector distance at all tilt angles. Usually this is done with a small 130 

goniometer head mounted on the large instrument goniometer. On it the sample can be 131 

translated and rotated. 132 

• The exact detector distance and detector orientation, as well as instrument peak 133 

broadening parameters need to be calibrated at least once. This is done with a powder 134 

standard such as cubic CeO2 (a = 5.4116 Å, see SRM674b-NIST certificate and also 135 

Yashima et al., 2003) or LaB6 (a = 4.15689 Å, see SRM660b-NIST certificate, and also 136 

Chantler et al., 2004) just before and/or immediately after the diffraction experiment on 137 

the textured sample. With LaB6 a higher d-range is accessible. Using the standard the 138 

detector geometry and instrumental part of diffraction peak broadening are refined for the 139 

calibration and then kept constant during the Rietveld analysis of the sample. 140 

• You need to know detector dimensions and characteristics. As an example the 141 

Perkin Elmer amorphous silicon large area detector used for the coin study at APS has 142 

dimensions of 2048x2048 pixels and a pixel size of 200x200 µm. 143 

 144 
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III. INSTRUMENT AND DETECTOR CALIBRATION WITH THE RIETVELD 145 

METHOD 146 

While experiments are fast, data analysis is quite involved to advance from diffraction 147 

images to quantitative orientation distributions. The Rietveld method (Rietveld, 1969) was 148 

originally developed for structure analysis from neutron powder diffraction patterns and has been 149 

greatly expanded since then. Currently freely available software versions that implement 150 

quantitative texture analysis are the General Structure Analysis System (GSAS; Von Dreele, 151 

1997; Larson and Von Dreele, 2004) and Materials Analysis Using Diffraction (MAUD; 152 

Lutterotti et al., 1997; Lutterotti, 2010). Vogel et al. (2004) compared results for neutron 153 

diffraction texture analysis by these two programs. 154 

In this section we focus on image processing and calibration. Independent from the type of 155 

analysis to be done, we need to measure and analyze first an appropriate standard to calibrate the 156 

2D detector (distance, center, tilting and also the wavelength if it not known with accuracy) and 157 

then use the calibration for the subsequent analyses with the actual samples. 158 

One way to perform the detector/image calibration is with graphical routines as implemented 159 

in software Fit2D (Hammersley 1998, download from 160 

http://www.esrf.eu/computing/scientific/FIT2D/). In Fit2D the “calibrant” method is used for the 161 

standard. After choosing a few points on an inner diffraction ring, the program will find the best 162 

center (x and y detector coordinates), detector tilting errors and detector distance or wavelength, 163 

by fitting the maximum intensities on a certain number of points on the Debye rings with the d-164 

spacings from the standard. We advise not refining both distance and wavelength as they are 165 

highly correlated at low angles (high energy). Here we did not refine the wavelength. The 166 

procedure of Fit2D is quite precise and accurate, but in this paper we propose a different way to 167 

perform the detector calibration to resolve possible problems arising later with the analysis of the 168 

actual samples, in particular: 169 

- The Fit2D procedure treats the deviation of Debye rings from perfect circular shape (i.e., 170 

ovals) as due to tilting errors of the detector, excluding other causes such as 171 

macroscopic mechanical strains in the sample such as for in situ high pressure 172 

experiments. This could be corrected if the centering of the images does not change 173 

between the standard and the strained sample, but this is often not the case. 174 
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- In the case of a highly textured sample or a nanocrystalline material, it is very difficult to 175 

determine accurately the image center graphically using these procedures as the Debye 176 

rings are more like distributed points or segments, or the lines (especially of 177 

multiphase/disordered materials) are too broad for a precise localization of the maxima. 178 

- In case the texture is not of interest, a common procedure is to integrate over the whole 179 

Debye rings to reduce everything to only one “randomized” pattern. Eventual centering 180 

errors or deviation of rings from round shape are then causing additional broadening of 181 

the diffraction lines with no possibility to correct such errors later. 182 

The procedure implemented in the Rietveld software MAUD (Lutterotti, 2010) relies instead 183 

on a first reduction of the diffraction image into several patterns using a graphical centering with 184 

no tilting errors. This pre-centering does not need to be perfect. The original image coordinates 185 

are recorded for each point of each pattern. The errors in centering and tilting are subsequently 186 

refined during the Rietveld refinement along with the other parameters, using a calibration 187 

function that calculates each time the correct 2θ value of all data points based on the actual 188 

values of such parameters. 189 

The formula used for the transformation of the image coordinates into 2θ is the following: 190 

δ
δ

θ tan
cos

)2cot( −=
r

D
,       (1) 191 

where 192 

r

yx yxy δδδ
δ

sinsincos
tan

+−
= ,     (2) 193 

22 yxr += ,        (3) 194 

cr xxx ∆−= ηcos  is the image coordinate x from the true center, (4) 195 

 sin cr yxy ∆−= η  is the image coordinate y from the true center, (5) 196 

D is the sample-to-detector distance, δx is the detector tilting along x axis (rotation around y 197 

axis), δy is the detector tilting along y axis (rotation around x axis), ∆xc is the x centering error, 198 

and ∆yc is the y centering error. 199 

During the reduction of patterns we save for each point the radial distance from the original 200 

center and the angle η of the pattern (angular coordinate around the diffraction rings, from 0 to 201 

360°, Figure 4a). 202 
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This procedure has several advantages: 203 

- the calibration inside the Rietveld least squares refinement is much more effective and 204 

accurate than on the image because it uses the entire peak profile and not only a 205 

maximum of the circle lines; 206 

- the centering can be refined also for difficult cases such as nanocrystalline sample, fiber 207 

diffraction or highly textured samples; 208 

- we can separate the deviation of Debye rings from round shape due to anisotropic 209 

macroscopic strains from detector tilt as these two have a different dependence on 2θ; 210 

- we observe generally an improved peak resolution and separation using this procedure 211 

over Fit2D due to the better centering and tilting correction (especially for high 212 

angle/low energy experiments). 213 

The procedure is quite efficient and can be applied also to detectors in asymmetrical 214 

positions and not perpendicular to the beam. In this paper we will only show the case of a 215 

detector roughly perpendicular and centered with respect to the beam. 216 

The procedure in MAUD always corrects the 2θ position of the experimental points rather 217 

than the calculated position of the diffraction peaks. The same applies to other instrumental 218 

errors like a 2θ displacement used in the traditional Bragg-Brentano geometry. The Fit2D and 219 

MAUD methodologies give similar results as long as the 2θ correction is small. 220 

In Table 1 we compare results of the detector calibration using the “calibrant” procedure in 221 

Fit2D and by fitting directly in Maud. Two standards and wavelengths have been used. The 222 

CeO2 corresponds to the APS experiment, LaB6 data were collected at XRD1 of the Elettra 223 

synchrotron in Trieste (image plate detector). The center y coordinate in Fit2D has been 224 

converted to the MAUD convention (the 0 for y is on the top-left corner and the coordinate goes 225 

down; in Fit2D is lower-left corner and goes up). Also the signs of the detector tilts has been 226 

reversed in Fit2D to compare with the MAUD convention. We notice considerable differences, 227 

far beyond the estimated standard deviation.  228 

The stack of experimental spectra can be viewed with the “Plot 2D” tab in which all 229 

individual 72 patterns is displayed (Figure 5a). This image is after instrument corrections have 230 

been refined and diffractions appear as straight lines.   Figure 5b is the sum of individual patterns 231 

(“Plot”) with tick marks below showing positions of diffraction peaks. Crosses are experimental 232 

data points and the line represents the Rietveld fit. Note that in not only reproduces positions and 233 
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intensities but also peak shapes. For diffraction data a square root scale for intensity is quite 234 

useful, as smaller peaks are more visible.  235 

The full step-by-step procedure in MAUD to calibrate the detector and instrument parameters 236 

is reported in Appendix 1 and corresponding data files can be downloaded from http://PD-237 

journal. 238 

 239 

IV. NICKEL COIN ANALYSIS 240 

Once we have calibrated the detector and determined the instrument resolution we can 241 

proceed with the analysis of the coin. 242 

To perform a texture analysis we need a sufficient number of data in order to measure a 243 

representative number of grains in different orientations. We need to cover the entire orientation 244 

space to ensure the validity of the results. For the estimation of the microstructure we rely on 245 

diffraction line broadening and for this it is critical to have a good characterization of the 246 

instrumental line broadening that is obtained during the experiment with the standard. The 247 

refinement strategy for the microstructural characteristics of the sample in MAUD is different 248 

than in other Rietveld programs such as GSAS. There is a clear separation between the 249 

instrument line broadening model and the line broadening model related with the sample. This 250 

permits to refine directly only the quantities of interest concerning the sample and keep constant 251 

parameters associated with the instrument. 252 

The general procedure with the sample analysis is to do the integration of each image in 253 

slices using the same center and parameters used for the integration of the standard image. Then 254 

we use the same distance, centering and tilting errors as refined in the standard analysis. If the 255 

beam centering did not change we should have a perfect calibration of the patterns (e.g., 256 

transformation of detector coordinates to 2θ angles). But having all the patterns around the center 257 

separated in slices we can also refine centering errors if necessary. In this analysis we will refine 258 

the centering for the sample, as in general it is not the same as for the standard. The center of the 259 

Debye rings corresponds to the position of the diffracting volume of the sample. For the coin 260 

sample it correspond to the beam position as the beam is entirely inside the sample; but the CeO2 261 

standard powder was in a capillary and thus the standard was entirely in the beam, and its 262 

position inside the beam defined the centering. 263 
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The only difference with the image integration with respect to the standard is that we choose 264 

a different azimuthal integration step around η (eta) angle based on the texture strength and/or 265 

grain statistics. We use a 5° step to integrate along the diffraction rings (corresponding to 72 266 

patterns per image). It is important to check the original diffraction image and regular intensity 267 

variations around diffraction rings. The size of the integration step should be chosen sufficiently 268 

small so that variations (and corresponding ODF peculiarities) are clearly distinguishable. But on 269 

the other hand, intensity variations due to poor grain statistics (‘spotty’ diffraction images) 270 

require the larger integration steps to effectively increase grain statistics. We have to determine if 271 

one image is sufficient to calculate the ODF. It depends on the crystal symmetry of the 272 

compound, on sample symmetry and, in principle, on the orientation distribution itself (e.g., 273 

when dealing with a polycrystalline phase where large parts of orientation space have 274 

corresponding ODF values equal to zero, the amount of necessary measurements greatly 275 

decreases, but such information is rarely available beforehand). In general it is advantageous to 276 

have several images providing a wider pole figure coverage (Figure 4b versus 4a). 277 

We will start the analysis using only one image (ω = 0°, with the beam perpendicular to the 278 

coin’s face) (Figure 4a) and then add other images to improve the ODF coverage (Figure 4b). In 279 

the tutorial (Appendix 2) we will show the step-by-step procedure with all images. The image 280 

has been loaded as for the standard and integrated in 5° step in η to transform it into 72 281 

diffraction patterns (note that in Figure 4 we show 10° increments because it is easier to view). 282 

For the instrument description we import the parameters calibrated with the standard, and we 283 

only refine the error in centering (2 parameters: x, y) along with the general intensity and the 284 

background. We can refine the unit cell parameter of the phase (a) as both the detector distance 285 

and the wavelength are kept constant. 286 

After refining instrument parameters, backgrounds and lattice parameter we proceed with the 287 

refinement of texture and microstructure. The strategy is similar to a normal Rietveld refinement, 288 

taking into account that to fit intensities correctly we also need to refine the texture. 289 

There is only one phase in this sample and it is a f.c.c. copper structure with some nickel as 290 

atomic substitution. We start from a pure copper phase and substitute part of the copper with 291 

nickel (25 at.% of Ni) and adjust the unit cell parameter to accommodate this change. For the 292 

microstructure, we choose the default line broadening method in MAUD that correspond to the 293 

simple “Delft” model (see De Keijser et al., 1982 and Delhez et al., 1993) and isotropic 294 

Page 10 of 38

Cambridge University Press

Powder Diffraction



For Review
 O

nly

11 
 

 

crystallite size and microstrain for the phase. This simple model which attributes Lorentzian 295 

broadening for the finite crystallite size and Gaussian broadening for the microstrain is sufficient 296 

to describe the diffraction profile of the Cu-Ni phase in this sample. No anisotropic peak 297 

broadening was observed. 298 

For texture model we choose EWIMV (the algorithm is described in Lutterotti et al., 2004) 299 

that has all the features of the direct discrete WIMV method (Matthies and Vinel, 1982) but has 300 

been reformulated to work within the Rietveld method. The EWIMV is able to work with 301 

arbitrary pole figure grids. The value Phkl on the pole figure for a certain reflection hkl can be 302 

computed using a numerical integration (here denoted with an integral) of ODF values over the 303 

proper path inside the orientation space that is considered to be discrete (divided onto quasi-304 

rectangular cells). Instead of using only the ODF values in the cells that the path is crossing, in 305 

EWIMV all neighboring cells are also included, weighing their contribution by the inverse of the 306 

distance of their center from the path r (a ‘tube projection’, Pawlik, 1986): 307 

 308 

∫ ∑
=

=
N

i i

i

h
r

f

K
P

1

1
,         (6) 309 

where ∑
=

=
N

i ir
K

1

1
,         (7) 310 

 311 

fi is the ODF value in the cell i and N is the number of cells including the neighboring ones. The 312 

use of such a tube projection ensures that the resulting orientation distribution will be sufficiently 313 

smooth, also in the case of poor pole figure coverage. There are other texture models available in 314 

MAUD. The harmonic model can be useful for weak textures, especially of phases with high 315 

crystal symmetry, but it suffers from “ghost” effects due to omission of odd coefficients in the 316 

harmonic expansion. For very strong textures standard functions (fibers or spheres in the 317 

orientation space) can be used (this will be demonstrated in Part II for shale). Different texture 318 

models have been discussed by Kocks et al. (2000, Chapter 3). 319 

For a single diffraction image with no more than 9 reflections over the entire 2θ range 320 

measured (including the partially visible reflections on the corners of the image), it is important 321 

to ensure a sufficient coverage. We start with a cell size of 15° in EWIMV and no sample 322 

symmetry. At the end of the refinement with MAUD we check the quality of the fit comparing 323 
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measured and calculated model patterns graphically with a 2D display (Figure 6) and evaluating 324 

R factor values. There are different R factors to evaluate the quality of the refinement; some 325 

apply to the Rietveld refinement of diffraction data and others to the texture calculation from 326 

experimental pole density values. For both we use Rw which is the weighted R-factor (Table II). 327 

Note that the R-factor is a single number to describe a very complex situation (as discussed by 328 

Toby, 2006) and in the end the 2D display is more reliable to assess the quality of fit, including 329 

texture (Figure 6). The coverage of the orientation space by data can be assessed with a function 330 

that calculates the number of “hits” (number of integration paths through each cell in orientation 331 

space) and values of “weights” for each cell in the orientation space (this plot can be activated 332 

from inside the EWIMV options panel after at least one computation is performed). 333 

In the MAUD console we can also retrieve the values for the R factors of the texture 334 

computation and the minimum-maximum values of “hits” and “weights” for the coverage. 335 

Looking at Table II, using 15° cells and only 1 image, the minimum number of hits is 42 and 336 

also the weight is not too low. But as we decrease the cell size the “hits” number decreases (at 337 

the same time R decreases). For 7.5° cells we have a minimum of 3 hits and less than 1E-3 for 338 

the weight. Note that three hits is the limit for WIMV to resolve an orientation. By adding the 339 

other 4 images collected at different ω angles we see a pronounced increase in the coverage. 340 

Even in the case of 7.5° cells we have the minimum of 43 “hits”. The Rw increases as now we are 341 

using much more data and resolve more details of the ODF. Figure 8 compares pole figures for 342 

some models. The 1 image, 10° cell case (Figure 8a) shows a remarkably similar pattern to the 5 343 

image case (Figure 8b). The 5 image, 5° cell case (Figure 8c) is considerably noisier and at the 344 

limit of resolution. After all, images were collected at 20° ω increments, resulting in a very 345 

spotty 5° ODF coverage. For the 5 image, 10° cell case an ASCII file of the ODF was exported 346 

and further processed in BEARTEX (Wenk et al. 1998). Figure 7d compares the BEARTEX plot 347 

with a corresponding MAUD plot (Figure 7b). 348 

From the microstructure model in MAUD we get a mean dimension of the coherently 349 

scattering crystallites around 500 nm and the true grain size may be even larger. Generally, for 350 

sizes larger than 200 nm diffraction patterns become almost insensitive to crystallite size. 351 

The texture is a strong cube texture superposed on a weak rolling texture. In a cube texture 352 

{100} is parallel to rolling direction (RD in Figure 7d), transverse direction (TD) and the 353 

direction normal to the rolling plane (coin surface) in the center of the 100 pole figures. Cube is 354 
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indicative of recrystallization (e.g., Schmidt and Lücke, 1979) and for a discussion of the 355 

transition from rolling to cube during recrystallization see Figure 40 in Chapter 4 of Kocks et al. 356 

(2000). 357 

The full step-by-step procedure in MAUD to perform texture analysis on the coin sample is 358 

summarized in Appendix 2 and corresponding data files can be downloaded from http://PD-359 

journal 360 

 361 

V. CONCLUSIONS 362 

Synchrotron X-rays provide a powerful method for quantitative texture analysis of materials. 363 

Depending on sample size, beam size and wavelength, small (< 100 µm3) to large volumes (> 364 

200 mm3) can be analyzed. Compared to neutron diffraction, electron backscatter diffraction or 365 

pole-figure goniometry, data acquisition is fast and images display immediately qualitative 366 

texture effects. 2D diffraction images are investigated with the modified Rietveld method, 367 

allowing to refine microstructural parameters, phase volume fractions and texture. For simple 368 

materials (in this case a coin) the refinement is straightforward and much can be done with an 369 

automatic wizard in MAUD software within a few minutes. 370 

 371 
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Tables 477 

Table I. Comparison results for CeO2 and LaB6 of the detector calibration using the “calibrant” 478 
procedure in Fit2D and then fitting in MAUD or by fitting directly in MAUD the calibration 479 
parameters of the detector. Parameters without standard deviations (in parentheses) have not 480 
been refined in MAUD. 481 
Standard (λ) CeO2 (0.10798 Å) LaB6 (0.7093 Å) 
Calibration Fit2D MAUD Fit2D MAUD 
Center x (mm) 205.189 205.0897(3) 81.772 81.745(2) 
Center y (mm) 204.751 204.7559(4) 81.674 81.6395(2) 
δx (˚) -0.093 -0.080(3) 0.258 0.2899(6) 

δy (˚) 0.092 0.031(4) -0.591 -0.6417(6) 
Distance (mm) 1852.085 1850.584(2) 129.3505 129.344(3) 
a (calibration) 5.4116 5.4116 4.15689 4.15689 
a (refined, MAUD) 5.41312(3) 5.4116 4.15707(3) 4.15689 
Rwp (%,MAUD) 4.14 8.4 2.13 6.91 
2θ error (MAUD) -0.00088(3) - -0.001(2) - 
 482 
 483 
 484 
Table II. Refinement and texture results for the coin analysis for different strategies. See text for 485 
an explanation. ODmax is texture maximum in m.r.d. 486 

Rietveld EWIMV OD Coverage 
images Rw 

(%) 

Parameters  Data 
number 

Cell 
size 

Rw 

(%) 

OD 
max 

Weight 
min 

Weight 
max 

Hits 
min 

Hits 
max 

1 27.2 12 50799 15˚ 23.3 57.4 0.073 0.91 42 195 
1 17.3 12 50799 10˚ 10.9 50.0 0.014 0.34 14 99 
1 14.4 12 50799 7.5˚ 7.1 23.7 0.0009 0.19 3 75 
5 23.1 48 255155 10˚ 22.3 48.0 0.062 1.62 104 470 
5 20.3 48 255155 7.5˚ 18.8 35.4 0.013 0.81 43 296 
5 16.9 48 255155 5˚ 10.4 48.7 0.0015 0.31 10 156 

 487 
488 
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Figure Captions  489 

 490 
Figure 1. Geometry of a synchrotron diffraction texture experiment. 491 
 492 
Figure 2. Typical sample for a hard X-ray diffraction experiment: Nickel coin mounted on a pin. 493 

Figure 3. Diffraction images with Debye rings measured at APS 11-IDC. (a) CeO2 standard, (b) 494 
Nickel coin, ω = 0°. Images are before rotation in ImageJ. 495 

Figure 4. Pole figure coverage with a single image (a) and with the sample rotated to different 496 
positions (b). Definition of rotation angles is indicated. (c) Coverage after a 90° rotation to obtain 497 
a view looking down on the coin. (10° is used for η increment). 498 
 499 
Figure 5. Diffraction patterns for CeO2. (a) Stack of experimental diffraction patterns after 500 
refinement of detector; diffraction lines are straight (b). Fit of all 36 patterns of (a) summed 501 
together using the calibration procedure inside MAUD.  502 
 503 
Figure 6. Nickel coin. Observed (bottom) and calculated 72 diffraction patterns (top) at end of 504 
refinement. ω = 0° image. “Plot2D” display. Lattice plane indices are indicated. 505 
 506 
Figure 7. Plot of pole figures, comparing different coverages. (a) 1 image, 10° OD resolution; (b) 507 
5 images, 10° OD resolution; (c) 5 images, 5° OD resolution; (d) 5 images, 10° OD resolution, 508 
processed with BEARTEX. Equal area projection, upper hemisphere, Pole densities in multiples 509 
of random distribution. 510 
 511 
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Figure 1. Geometry of a synchrotron diffraction texture experiment.  
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Figure 2. Typical sample for a hard X-ray diffraction experiment: Nickel coin mounted on a pin.  
17x14mm (300 x 300 DPI)  
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Figure 3. Diffraction images with Debye rings measured at APS 11-IDC. (a) CeO2 standard, (b) Nickel coin, 
ω = 0°. Images are before rotation in ImageJ.  

170x90mm (300 x 300 DPI)  
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Figure 4. Pole figure coverage with a single image (a) and with the sample rotated to different positions (b). 
Definition of rotation angles is indicated. (c) Coverage after a 90° rotation to obtain a view looking down on 

the coin. (10° is used for η increment).  

105x35mm (300 x 300 DPI)  
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Figure 5. Diffraction patterns for CeO2. (a) Stack of experimental diffraction patterns after refinement of 
detector; diffraction lines are straight (b). Fit of all 36 patterns of (a) summed together using the calibration 

procedure inside MAUD.  

333x135mm (300 x 300 DPI)  
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Figure 6. Nickel coin. Observed (bottom) and calculated 72 diffraction patterns (top) at end of refinement. ω 

= 0° image. “Plot2D” display. Lattice plane indices are indicated.  
1313x887mm (72 x 72 DPI)  

 

 

Page 25 of 38

Cambridge University Press

Powder Diffraction



For Review
 O

nly

  

 

 

Figure 7. Plot of pole figures, comparing different coverages. (a) 1 image, 10° OD resolution; (b) 5 images, 
10° OD resolution; (c) 5 images, 5° OD resolution; (d) 5 images, 10° OD resolution, processed with 
BEARTEX. Equal area projection, upper hemisphere, Pole densities in multiples of random distribution.  

265x336mm (300 x 300 DPI)  
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Rietveld Texture Analysis from Synchrotron Diffraction Images: I. 

Calibration and Basic Analysis 
Luca Lutterotti1), Roman Vasin2,3), Hans-Rudolf Wenk2) 
1) Department of Industrial Engineering, University of Trento, Italy 
2) Department of Earth and Planetary Science, University of California, Berkeley CA 94720 
3) Frank Laboratory of Neutron Physics, Joint Institute for Nuclear Research, Dubna, Russia 
 
Figure numbers and references refer to main paper. 

 

Download data files from the internet: 
Refer to web page: http://www.ing.unitn.it/~maud/Tutorial/ImagesPowderDiffraction or 
http://eps.berkeley.edu/~wenk/TexturePage/MAUD.htm. The MAUD-Part-I.zip contains: 

Diffraction image for CeO2 standard: CeO2-00010.tif 
Crystallography information file (crystal structure) for CeO2: CeO2.cif 
Diffraction images for Nickel coin: Nickel-00182+40.tif Nickel-00182+20.tif, Nickel-

00182+0.tif, Nickel-00182-20.tif, Nickel-00182-40.tif 
MAUD parameter file for Nickel coin with completed analysis (for checking): Nickel-coin.par 

 

Appendix 1. Step-by-step procedure of image processing and instrument 

calibration with CeO2 standard. 
MAUD is written in Java and works with any operating system for which a Java 

implementation is available (Windows, Mac OS X, Linux, and Unix). It requires a large amount 
of memory (at least 2 or 4 GB is recommended for most cases where texture is involved). The 
latest version of MAUD can be downloaded from http://www.ing.unitn.it/~maud and installed 
into an own directory. A recent version of Java (1.6 or higher) also has to be installed 
(http://www.java.com). To run MAUD, use the MAUD.bat file in Windows systems, or 
MAUD.sh in Linux/Unix. Before running this tutorial, it may be useful to follow first one of the 
tutorials at http://www.ing.unitn.it/~maud/tutorial.html or check the video tutorials at: 
http://www.youtube.com/user/MaudRietveldProgram. 

When you run MAUD for the first time, a window will open with many options and displays 
as shown in Figure A1-1. It has three main tabs (left side, top): “Datasets”, “Phases” and 
“Sample”. Most frequently used commands are present as icons in the toolbar, e.g., “Disk” to 
save current analysis, ”Eye” to edit a selected object, “Calculator” to compute model diffraction 
patterns, “Hammer” to start a refinement, etc. 
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Figure A1-1. Main MAUD window on computer running Windows 7. Superposed is a window 
“DataFileSet” with options and settings for the selected Dataset. At the start the plot window is blank. 
Here data for CeO2 standard have been entered and refined. 
 
1. Defining the instrument 

An instrument is defined for each dataset. Select the default dataset under “Datasets” and 
edit it (menu: “Edit→Edit object”), or click the “Eye” icon in the toolbar. Locate “Diffraction 
Instrument” in “Instrument” panel under “General” tab, and click “Edit” button. This opens the 
Instrument editing window (Figure A1-2). 

 

 
Figure A1-2. “Diffraction Instrument” window with general setup for synchrotron diffraction images. 
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• Rename the instrument to “APS-BESSRC 11-ID-C” so you can add it later to the instrument 

database and recognize it when needed. 
• Adjust “Incident intensity” value to 0.001. 
• Check that the option for “Intensity calibration” is “none cal”. 
• Choose as “Angular calibration” model: “Flat Image Transmission”; click “Options” button 

next to it and change the “Detector distance” to 1850 mm. The distance is needed for the 
conversion of image coordinates to 2θ; for now it is just an estimate and this value will be 
refined later. MAUD accepts data in 2θ, d-spacing or Q; everything else needs to be 
transformed by a calibration model. 

• For “Geometry” choose “Image 2D”. 
• For “Measurement choose “2Theta”. 
• For “Source” select “Synchrotron”, click “Options” and change default wavelength to 

0.10798 (Å). 
• In “Instrument Broadening” we should set the default parameters to be in line with 

synchrotron diffraction. Click “Options” button next to the “Caglioti PV” model (Caglioti et 

al., 1958) and remove the asymmetry parameters (or set them zero). Under “HWHM” tab set 
all parameters to zero except for the first (the constant value, equal to W of the Caglioti 
formula), set it equal to 0.00025. 
Close the Instrument editing window. 
 

2. Entering 2D image data 
With the ImageJ plugin embedded in MAUD a .tif image file can be directly entered into 

MAUD and saved as .esg files, which are ASCII files containing a list of radial positions or 
diffraction angles and corresponding experimental intensities. If the diffraction data is in another 
detector format not recognized by ImageJ, it has to be converted into a regular .tif file, 
preserving the original intensities (e.g. for MAR detector images we advise to use the converter 
utility “marcvt”, freely available from http://www.marresearch.com/download.html. Running 
marcvt in Microsoft Windows requires Cygwin (http://www.cygwin.com) with libjpeg7 and 
libpng12 packages. We found that using for example Fit2D for the conversion, image 
coordinates are inverted. Also the pixel dimension is lost in the conversion and needs to be 
reentered in MAUD/ImageJ before the integration). 
To perform the integration in MAUD using the ImageJ library, remain in the “Datasets” window, 
select “Datafiles” tab (Figure A1-3). Then press the button “From images..” to start the ImageJ 
plugin. A small window with the typical ImageJ toolbar will appear (Figure A1-4, top right). 
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Figure A1-3. “Datafiles” in Dataset options window for CeO2 standard, viewing one of the diffraction 
patterns (.esg file) in the insert. Initially there are no data in the window. In the view here they have been 
loaded “From images”. 

 

 
Figure A1-4. ImageJ setup for image processing to generate diffraction patterns by azimuthal integration 
of the 2D image. The start of η (diffraction pattern #0) is indicated. The small arrow points to the circle 
used for aligning the image in the center (this circle is red in the color display). 
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• From the ImageJ menu “File→Open…” load the image CeO2-00010.tif. 
• From menu “Image→Adjust→Brightness/Contrast” use the “Auto” button as many times as 

you need, until you can see clearly also weaker diffraction circles or spots. Close this 
window. 

• Select “Image→Properties”, change “Unit of length” to mm and “Pixel width” and “Pixel 
height” to 0.2 for the Perkin-Elmer detector (200 µm/pixel) and press “Ok”. Now on the top 
of the image window you should read “409.60x409.60 mm (2048x2048); 32-bit; 16MB” 
(Figure 11). 

• Next we have to rotate the image 90° to bring the ω rotation axis for sample tilt into the 
origin of η to conform to the angle convention in MAUD (Figure 4a). Select 
“Image→Transform→Rotate 90 Degrees Left”. When using later the calibration done with 
this standard we have to apply the same rotation to all sample images. 

• Pick the “Rectangular” selection (first button in the ImageJ toolbar) and select the ROI 
(Region Of Interest) to be integrated by dragging the mouse over it. If necessary, it is 
possible to resize it to include only diffraction rings of interest and leave out the borders 
where intensities may be masked or distorted. 

• Now proceed to the “Plugins→Maud plugins→Multi spectra from normal 
transmission/reflection image”. The previous rectangular selected area will change to a red 
circle that now is just a tracker symbol for user’s convenience. The diffraction image 
appears as illustrated in Figure A1-4 (left) and next to it a “Choose the integration lines” 
window shows a list of parameters (Figure A1-4, right). For this sample, Sample-Detector 
distance is 1850 mm. If necessary adjust “Center X (mm)” and “Center Y (mm)” to bring 
the tracker circle (red) into the center (X = 204.85 and Y = 204.79). Adjust the tracker radius 
and update the plot (click “Update” not “OK” to view changes). Set the “Number of 
Spectra” to 72, i.e. the image will be integrated in 5° sectors. The start of the integration is 
indicated on Figure A1-4 (left) and the sense is counterclockwise. For each azimuthal step 
the integration is done for the region from η–2.5° to η+2.5°. Set Omega (ω) to 90° to bring 
the normal to the sample into the center of the pole figure (see section IV and Figure 4c), 
leave the rest to 0. Be sure that “Reflection image” and “2-Theta angles calibrated” options 
are unchecked (this is a transmission image and we want to use the calibration model in 
MAUD). 

• Hit “OK” and the integration should start right away. After the integration is done, the 
program will ask to save the files as ASCII data. Choose the directory in which you have 
your data and want to perform the analysis (better not the MAUD directory). Here we give it 
a name CeO2-00010 (it is good practice to use the same name as the image) and the program 
will automatically assign “.esg” as file extension. 

• Close the diffraction image and ImageJ windows and return to the MAUD dataset editing 
window, where the .esg files are now listed in the “Spectra list” panel. If you close the 
dataset window, a summation of all patterns should be visible in the plot panel of the main 
MAUD window (Figure A1-1). 
 

3. Refinement range and background 
There are no diffraction peaks at 2θ < 1.6°, so we restrict the refinement range in the 

“General” tab of the dataset editing window (Fig. A1-1, insert) by changing “Min in data units” 
and “Max in data units” values. Units are those of the actual diffraction data (in this case 2θ in 
degrees). Enter 1.6 as Min and 8 as Max. 
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Choose the background model (switch to “Background function” tab). By default a 
polynomial background is used in MAUD, and we use 5 parameters to approximate background 
by a 4th order polynomial (click “Add parameter” or “Remove parameter” buttons to change the 
number of parameters to 5). It is possible to assign individual backgrounds to each diffraction 
pattern. In the “DataFileSet” window under “Datafiles” tab, select all patterns (i.e., select one 
and press CTRL+A on PC, or CMD+A on Mac) and in “Command shortcuts” panel add 
necessary number of local background parameters (click “Add bkg par” button several times; 
i.e., three clicks will add a background function as a 2nd order polynomial to each of the selected 
patterns). This is not necessary here. 

With this the initial setup of the diffraction instrument and the input of diffraction data is 
completed. 

 

4. Phase and initial parameters adjustment 

“Phases” tab in main MAUD window contains crystallographic and microstructural 
information on all the phases in the sample such as lattice parameters, space group symmetry, 
atomic positions, grain size, texture, etc. By default it is empty. The basic parameters can be 
entered as “crystallographic information files” (.cif) which can be downloaded, e.g., from 
databases like the ICSD (ICDD) or the COD (http://www.crystallography.net, Gražulis et al., 
2009) or AMCSD (http://rruff.geo.arizona.edu/AMS/amcsd.php, Downs and Hall-Wallace, 
2003). Some example phases are also contained in the MAUD file “structures.mdb” which 
comes with the installation package. To import a structure from a .cif file click the “Cylinder 
with arrow out” icon on the toolbar or select “Edit→Load object from CIF…” menu. 

A structure model can also be built manually and with “Cylinder with arrow in” icon and 
saved as a .cif file for later use. To do this: 

• While on “Phases” tab click the icon with the picture of a box in the toolbar (or select 
“Edit→Add new object” menu). 

• In the “Phases” list “Phase_x” appears. It can be renamed by double clicking on it. 
• Select the desired phase and “Edit” it. 
• In “General” tab enter space group, and lattice parameters (for monoclinic structures first 

setting has to be used and for rhombohedral lattices, hexagonal setting needs to be used to 
comply with texture analysis conventions). 

• In “Structure” tab add atomic sites to create the structure. Once a site is added, the name 
can be changed by double clicking the entry in the list. 

• For each site, the atom type can be changed by clicking “Atom type” and selecting the 
appropriate atom from the Periodic table that will appear. It is possible to select the oxidation 
state (meaningful for x-ray scattering only) or isotope (for neutron scattering only). 

• Adjust atom coordinates, site occupancies, ionization state and thermal factors if needed. 
Sometimes thermal factors (especially anisotropic) are loaded incorrectly from the .cif file. 
Check them after you import a structure. 

• The created structure can be viewed in 3D by clicking the “Pointer finger” icon in the 
upper right corner of the structure tab window. 

Here we import the provided cerium oxide structure file CeO2.cif. After it is loaded, edit the 
CeO2 phase. In its properties window switch to “Microstructure” tab, and click “Options” button 
next to “Size-Strain model: isotropic”. There set the crystallite size and microstrain values to 
5000 (Å) and 1.0E-5 (in means very little peak broadening from the phase). 
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After having entered all this information, pressing the “Calculator” button (or from menu 
“Analysis→Compute spectra”) in the main page (Figure A1-1) computes diffraction patterns 
based on user-provided instrumental and phase parameters and compares them with experimental 
data. This can be viewed with the “Plot” tab above the pattern in MAUD main window which is 
an average over all patterns from a dataset, or with the “Plot 2D” tab in which a stack of all 
individual 72 patterns is displayed (experimental patterns are at bottom and model patterns are 
on top) (Figure 5). For diffraction data a square root scale for intensity is quite useful, as smaller 
peaks are more visible. This can be set or changed in “Graphic→Plot options” menu. 

Next we want to adjust the scale factor (beam intensity in MAUD) as the calculated intensity 
data are different from experimental values. This can be done “live” by using the parameter list 
at the bottom of the main MAUD window (Figure A1-1). Enlarge the tree-table and scroll until 
you see the parameter “_pd_proc_intensity_incident” under instrument in the dataset. Make sure 
the column “Value” of the table is sufficiently large by dragging its border if necessary. Click on 
the value of the parameter you want to change (one click). Two arrows and a field to the right of 
the parameter appear. The text field contains the increment by which you can change the 
parameter by clicking on corresponding arrows. The updated plot is displayed right away. After 
finishing adjustments click the mouse anywhere in the tree-table (except a value) to exit from the 
“editing” mode. Adjust the first background parameter “_riet_par_background_pol0” in the same 
way. 

Save your analysis as MAUD parameter file .par (e.g. name it CeO2-00010.par) in the same 
directory where your data are, using a menu item “File→Save analysis as…”. Do not just “Save 
analysis” because this would overwrite the default MAUD parameter file “default.par”. Your 
parameter file contains all information about instrument, phase and sample parameters and can 
be used as a starting analysis file for other images. 

 
5. Refinement procedure 

There are various ways to refine the parameters: 
• For a manual refinement the user goes through all parameters listed in the tree-table in the 

bottom part of the MAUD main window and changes their status from “Fixed” to “Refined” 
(or “Equal to…” to set a linear dependence between different parameters). This is quite 
cumbersome and only applicable for experienced users. Some parameters are correlated, and 
some have very low impact on the calculated diffraction pattern unless other parameters 
values are correct, and the refinement has to proceed in a systematic order. The parameters 
can also be viewed by editing objects under “Datasets”, “Phases” and “Sample” tabs. This is 
more intuitive because there the parameters are illustrated within their context, and with a 
right-click on the parameter you can also set it to “Refined” or “Fixed”. Once you have set 
all the parameters you want to refine, click the “Hammer” icon in the toolbar of the main 
page (or select “Analysis→Refine” menu). 

• Semi-automatic refinement is possible if the user selects the “Analysis→Parameters list” 
menu, which again displays the parameters list (click “Expand all” button below to see the 
entire tree-table of parameters expanded) but at the bottom there are “Commands” that 
allows user to change certain groups of parameters. A good start is to first “Fix all 
parameters” and then proceed with, e.g., “Free scale pars” (general intensities and phase 
volume fractions are set to “Refined”), “Free backgrounds” (all parameters for backgrounds 
are set to “Refined”), etc. in cycles. 
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• Automatic refinement is yet another way. For this option click the “Light bulb” icon in the 
toolbar (or go to “Analysis→Wizard” menu) to open “Refinement wizard” and proceed with 
refinement from top to bottom of the list on the left side, or a complete analysis on the right 
side. But there is no wizard option for instrument calibration as it can not be standardized. 
The refinement can be lengthy, depending on the complexities (number of patterns, number 

of diffraction peaks per pattern, utilization of complex texture/microstructure models, etc.). Do 
not change anything during the refinement! If you are reviewing some parameters in the course 
of the refinement, it is important to close all frames using the window close button (on all 
systems it is the button on the window title bar) and not with the “OK” button. The latter changes 
or refreshes the parameters in midst of the refinement and may cause the optimization to behave 
erratically. 

 
6. Refine scale factors and background 

We proceed with the mixture of semi-automatic and manual refinements (see step 5). Start 
with “Analysis→Parameters list” and first click “Fix all parameters”, then “Free Backgrounds” 
and “Free scale pars”. You may leave parameters list window open to return to it later. In the 
MAUD main window click the “Hammer” button in the toolbar and the least squares refinement 
will start. Choose the number of cycles with the slider appearing at the left side of the window 
(usually 3-5 is sufficient). If the refinement goes well, the calculated and experimental patterns 
on the display should become more similar (Figure 5b, dots are experiment, line is model). Save 
the analysis after each successful refinement. You may want to save under different names with 
“Save analysis as…” in case the refinement converges into a local minimum or diverges and you 
need to go back a step and make manual adjustments. 

 
7. Refine instrument parameters 

Next we refine instrument parameters. Edit “Dataset→Diffraction Instrument” (step 1). 
Under “Options” for “Flat Image Transmission” right click consecutively on values in red fields 
for the “Detector Distance”, “Center displacement x, and y”, “Tilting error x and y” and select 
“Refined” in each appearing popup menu. Close the windows and run the refinement again. This 
will adjust the reflection positions. 

Then it is necessary to refine the instrument broadening parameters in the “Caglioti PV” 
model. Caglioti parameters describe instrument broadening, especially peak asymmetry, peak 
width and Gaussian plus Lorentzian mixing parameter (Caglioti et al., 1958). These instrument 
peak shape parameters are essential if you want to assess peak shape effects of real samples, such 
as crystallite size and microstrain, or estimate dislocation density and stacking fault probability. 

Caglioti parameters are very sensitive and a strict order needs to be followed. We describe 
the procedure for synchrotron image data where the 2θ range is limited. With the initial 
parameters set as suggested in step 1, there should be no need for manual adjustments. 

If you feel (or discover during the refinement) that it is still necessary, then start adjusting 
the first HWHM parameter – “_riet_par_caglioti_value0” – manually by using the parameter tree 
list in the bottom of the main window with the “live” procedure (step 4). After that you may 
adjust the second and if necessary (for large 2θ range) the third HWHM to get an approximate 
fit. You can view an enlarged peak by selecting an area in the plot by mouse click and dragging. 
Afterwards you may return to full pattern view by double clicking in the plot or right-clicking 
and choosing “Reset scale” from popup menu. If you need to adjust the asymmetry, then for 
synchrotron diffraction data we advise to start with only one parameter 
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(“_riet_par_asymmetry_value0”) and enter a large value (> 5000) for it if the asymmetry is small 
(which is usually the case for synchrotron data). 

After this manual adjustment, you can proceed in the following order (3 iterations are 
sufficient in each of these steps; do not fix the parameters already set refined in previous steps or 
from beginning and be sure not to refine things like wavelength or parameters of the CeO2 
phase): 

• “_riet_par_caglioti_value0”, set refined and refine. 
• “_riet_par_caglioti_value1”, “_riet_par_gaussian_value0”, 

“_riet_par_gaussian_value1” set refined and refine. 
If you look at the plot window you can see that peak intensities are rather poorly fit. You can 

refine an overall thermal factor (“Edit” the phase, switch to “Structure” tab, right-click on the 
value of “B-factor”) but this will not solve the problem completely. We can do an intensity-
independent Le Bail fit for each pattern. “Edit” CeO2, switch to “Advanced models” tab and 
select “Arbitrary tex” as texture model. Next fix all the scale factors or intensity-related 
parameters as they are not needed with the Le Bail fitting (set fixed the 
“_pd_processing_intensity_incident” and the “_atom_site_B_iso_or_equiv” for the Ce1 atom 
site). Perform another refinement cycle. 

Sometimes after the refinement a message “Cholesky negative diagonal” appears in the 
MAUD output panel. This means the problem that MAUD was trying to solve was ill-
conditioned, and some of the parameters are not refinable at the given conditions. The first of the 
three displayed numbers refers to the “wrong” parameter. You can view it on the MAUD output 
file (with .lst extension) or you may review the parameters list window and find a refined 
parameter with value “-1” in the “Error” column. After determining the parameter you should 
either adjust it manually or refrain from refining it. 

 
8. Saving results 

In the end, the calculated peaks should fit the experimental peaks very well, both in the 
“Plot” and “Plot2D” displays (Figure 5). Be sure to save the parameter file at end. To export the 
instrument for use in the refinement of other samples, “Edit” the current datasets and under 
“General” tab click “Store…” button in the “Instrument” panel to save the instrument settings as 
a separate file in your directory (e.g. giving it a name such as CeO2-2012.ins). 

We have now refined the relevant instrument parameters with the CeO2 standard and can 
apply them to other samples measured under identical conditions. 
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Appendix 2. Step-by-step procedure for texture analysis of Nickel coin. 
Here we present the tutorial for the analysis of all five images but see discussion in section 

IV of the paper. 
1. Datasets 

Run MAUD, and create a new analysis (menu item “File→New→General analysis”). “Edit” 
the default dataset and under “General” tab in the “Instrument” panel click “Import…” to import 
the previously refined instrument file created in step Appendix 1-8 (CeO2-2012.ins). Next, in the 
main MAUD window, duplicate the dataset using “Edit→Duplicate object” menu item. This will 
create a copy of the selected dataset including instrument parameters. Repeat this until you have 
5 datasets (one for each diffraction image). Then rename the datasets (by double-clicking on its 
name) to, e.g., “Coin-40”, “Coin-20”, etc. up to “Coin+40”. 

Select the first dataset named “Coin-40” and repeat the step Appendix 1-2 to integrate the 
corresponding diffraction images of the coin sample: “Nickel-00178-40.tif”. Use the same values 
for the image size, image rotation (90 degrees left), center X, center Y etc. that you have used for 
CeO2. Only the number of patterns may be different (36 or 72 if you decide to integrate 
diffraction images in 10° or 5° sections), or the angles ω, χ and φ for the data collection. After 
the diffraction image integration is completed and patterns are loaded into MAUD, under 
“Datafiles” tab select all patterns, click “Modify Angles” button and change the ω angle (“New 
omega =” -40 + omega) to account for the sample tilt. For the coin it is appropriate to set the 
refinement range to 2.5-6.2°, as there are no diffraction peaks at lower 2θ values. In 
“Background function” use 5 polynomial parameters. 

Repeat these operations for each of the 5 datasets, importing corresponding diffraction 
images and adjusting ω angles accordingly. Note that if you have several datasets then the 
diffraction patterns shown in all displays in the main MAUD window correspond to the currently 
selected dataset. To see the patterns from any other dataset you must select it in “Datasets”. 
When finished importing instrument and all the data, save your analysis (e.g., “File→Save 
analysis as…” Coin-2012.par). 

 
2. Phase 

Go to “Phases” tab of the MAUD main window and import the copper structure from the 
MAUD database (structures.mdb). Select “Copper” from the list of available phases (“Choose a 
Phase to add” window) and click “OK”. The structure of copper needs to be modified to take 
alloy composition into account. “Edit” the copper phase, go to “Structure” tab, select the Cu1 
atom site in the “Site label” list and click “Duplicate”. This will make a copy of copper atom 
with the same coordinates, thermal factors, etc. Change the site name to Ni1 by double-clicking 
on it. Click the button next to “Atom type” and select Ni atom from the Periodic table appearing 
in a new window. Adjust “Occupancy” of Cu to 0.75 and of Ni to 0.25. 

In “Advanced models” tab select the texture model. Select “E-WIMV” from the drop-down 
list and press the “Options” button next to it. In “E-WIMV options panel” select 10° for “ODF 
resolution in degrees” (see the discussion in section IV). Click “OK” in the “E-WIMV options 
panel” to close the window. 

 
3. Sample 

In the MAUD main window go to “Sample” tab and “edit” current sample. Under “Sample 
position” change the sample orientation angle ω to 90° degrees. This will change the orientation 
of the sample with respect to conventional MAUD reference coordinate system so that in pole 
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figures we look down on the Nickel coin. To check the texture coverage, first compute the model 
diffraction patterns (use “Analysis→Compute spectra”, or “Calculator” icon), then go to the 
menu “Graphic→Texture plot”; select the hkl reflection for which you want to plot the texture 
coverage, in the “Pole figure options” panel select “Pole figure coverage” and press the “Plot” 
button. We set the pole figure projection plane parallel to the Nickel coin’s face (as in Fig. 2) and 
the corresponding coverage should be similar to the one displayed in Figure 4c. 

 
4. Refine coin data 

In a simple case like this, the automatic “Refinement Wizard” can be used for the refinement 
after an approximate fit has been established manually. 

Go to menu “Analysis→Wizard”. Select “Texture analysis” in the panel on the right and 
click “Go!”. This will perform the full texture analysis in 4 cycles. The first 3 cycles correspond 
to the refinement steps discussed in section IV (first, the refinement of backgrounds and general 
pattern intensities, then centering and unit cell parameters, then microstructural features); the 
fourth one refines the texture. Follow progress on the Plot2D display. For the first 3 cycles you 
will observe that the match of line positions and overall intensities between observed patterns 
(bottom) and calculated patterns (top) improve, but intensities in calculated patterns remain 
uniform. This changes dramatically in Cycle 4 (Figure 6) as texture is being refined. 

With all the following parameters: 10° integration step of diffraction images, 5 diffraction 
images in total, refinement range in 2θ is 2.5-6.2°, 5 background parameters for each dataset, the 
refinement (all 4 cycles, 5 iterations per cycle) takes less than 80 seconds on a laptop with Intel 
Core i7 3840QM and 32 Gb of DDR3 RAM (1600 MHz, CL11) running Microsoft Windows 7 
Ultimate x64 and 64-bit Java VM. If the integration of images is performed with 5° step, the 
computation time is increased by a factor of 2 (about 160 seconds). 

 
5. Checking the results 

After completion of the refinement, a first step is to check all datasets with the “Plot 2D” 
display to see if the intensity fit looks reasonable (Figure 6). You can also do this in a separate 
window by selecting “Graphic→MapPlot of selected dataset” menu. It may be also important to 
see how individual patterns are fitted. This is done by “Editing” a dataset of interest. Under 
“Datafiles” tab select one or several diffraction patterns and press “View” button. Sometimes just 
one or two patterns are fitted poorly, with obviously wrong peak positions, widths or intensities. 
You may remove such “wrong” patterns by unchecking their “Enabled” property in the same 
window. Repeat the refinement without them. 

Check the texture pattern by selecting “Graphic→Texture plot” menu (Figure 7a-c). A new 
window will appear where it is possible to plot selected pole figures hkl, inverse pole figures, 
strain distributions, etc. on equal area projection. Select the pole figures to plot (check “Active” 
next to a set of Miller indices), ensure that “Reconstructed intensity” (i.e., pole figures calculated 
from ODF) and “2D map” options are selected. Then press “Plot” button. In a sub-window you 
have the option to change maximum and minimum values for the pole figure plot. You can plot 
pole figures in color or “Gray shaded”. You may adjust the number of contours to draw with a 
slider in a bottom right part of the window, or smooth with a Gaussian filter (change “Gauss 
smooth width”). 
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6. Exporting texture for external programs 
Even though MAUD offers several options for plotting ODF and pole figures, it is advised 

to use specialized software for further texture processing. In the phase editing window under 
“Advanced models→E-WIMV→Options” you can export the ODF (“Export ODF formatted for 
Beartex”), or pole figures (“Export PFs”) as ASCII files for the BEARTEX texture package. The 
exported ODF is always interpolated into 5°x5°x5° cells and can be converted by BEARTEX 
into a binary format for further processing, including smoothing, rotations, representation and 
physical properties calculations. Figure 7d compares a BEARTEX plot with a corresponding 
MAUD plot (Figure 7b). 
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